• Page:
  • 1
  • 2

TOPIC: RRD File not finding column in table

Re:RRD File not finding column in table 22 Jan 2009 14:13 #373

  • mattholbrook
  • mattholbrook's Avatar
Hi,

When creating the rrd did you select Specified for the parameters and fill it in with a valid entry?

Thanks!
Matt
The administrator has disabled public write access.

Re:RRD File not finding column in table 22 Jan 2009 14:41 #374

  • Axminster
  • Axminster's Avatar
Yeah, but if I put prompt instead of specified (Yes, the specified order number is correct) it says: "Missing parameter values".
The administrator has disabled public write access.

Re:RRD File not finding column in table 22 Jan 2009 15:14 #375

  • mattholbrook
  • mattholbrook's Avatar
In order to email a report with a parameter you must specify the parameter. If you do that does it then run the solution correctly?

Thanks!
Matt
The administrator has disabled public write access.

Re:RRD File not finding column in table 22 Jan 2009 15:30 #376

  • Axminster
  • Axminster's Avatar
No, unfortunately. Not sure what to do about it. The viewer application reads the report no problem.
Solution Builder still reports these errors if it's set to just preview the file.
If I edit the file in notepad, I can change the column to include the table name, but then nothing happens...
The administrator has disabled public write access.

Re:RRD File not finding column in table 22 Jan 2009 15:41 #377

  • Axminster
  • Axminster's Avatar
Actually, I've just fiddled about with it.
It only works if you select "View" as the action but it won't print, save or email.
Do I need to buy the pro version?
The administrator has disabled public write access.

Re:RRD File not finding column in table 22 Jan 2009 15:41 #378

  • mattholbrook
  • mattholbrook's Avatar
If you want we can do a remote session so I can take a look at what is happening. You can email me at This email address is being protected from spambots. You need JavaScript enabled to view it..

Thanks!
Matt
The administrator has disabled public write access.

Re:RRD File not finding column in table 27 Jul 2009 17:31 #481

  • dstoller
  • dstoller's Avatar
Matt --

I am having the exact same problem with several rrd files. I may view a report on Logicity desktop and save as pdf. But if I attempt to save or email the same RRD directly, I receive a "column not found" error. What was the solution to this posting?

thanks,
Dale
The administrator has disabled public write access.

Re:RRD File not finding column in table 27 Jul 2009 17:35 #482

  • dstoller
  • dstoller's Avatar
and just to further define -- I have one parameter in the report that I define within the RRD.

thanks,
Dale
The administrator has disabled public write access.

Re:RRD File not finding column in table 28 Jul 2009 13:57 #483

  • aellis
  • aellis's Avatar
Good morning Dale,

I am working on a new build of Logicity and would like to track down as many bugs as possible to include fixes in the new version. Can I clear up a few things here:

1. So the issue you are seeing here is only with the E-mail, Print, and Save actions, right? If you do a View action you can press the export button to export the report to any format you like, right?

2. To clarify the parameters - your Crystal Report has only a single parameter and you have defined that parameter in your Logicity Solution File.

3. If you are using a view action with the parameter set to specified in the solution file it works without issue and does not prompt you for any additional information (database logins, other parameters, etc)

4. Is this only with a single report or have you noticed it with all reports? If you have a report without parameters does it work fine?

Lastly, can you give me a rundown of what database you are reporting against along with which version of Crystal your report was developed in?

Thanks,
Adam
The administrator has disabled public write access.

Re:RRD File not finding column in table 28 Jul 2009 14:47 #485

  • dstoller
  • dstoller's Avatar
Adam --

1. - Correct - view and then manual saving, printing, e-mailing works fine.

2. - Correct.

3. - Correct.

4. - All reports with any parameter fail. Reports without parameters run with success. The erroe is column not found.

5. - AS400 DB2 / client access ODBC driver / version 8.5.

It seems that my experience is similar to that of user "Axminster." We purchased and are using the professional version of Logicity.

Thanks for your help,
Dale
The administrator has disabled public write access.
  • Page:
  • 1
  • 2

Logicity Logo White 300

526 S Main St., Suite 805, Akron, OH 44311 USA
855.758.0100
sales@logicitysuite.com