TOPIC: Error Connecting to Oracle ODBC

Error Connecting to Oracle ODBC 07 Dec 2011 22:59 #915

  • Fiona
  • Fiona's Avatar
  • Offline
We are evaluating Logicity as our Crystal viewer solution. We have several databases on different platforms. I'm able to get the reports that run against SQL Server w/ Integrated authentication to work properly. We have many reports that run against an Oracle ODBC connection, which requires a username/password to connect. When I attempt to run one of these reports, I get:

Failed to open the connection.

No prompt for username/pass. The report runs fine on the same PC when run through Crystal Reports. Tells me that ODBC and the report are configured correctly.

Any help is appreciated. Thanks!

Kyle
The administrator has disabled public write access.

Logon error and auto refresh feature in v1.7 04 Aug 2012 05:28 #1058

  • pstymfal
  • pstymfal's Avatar
  • Offline
Hi,

1. We have login password for accessing the database, when we open the application, it will give us logon error and prompt us to enter the password. We are concerned if this is a bug or due to login password required to access the database. We overcome it by embedding the password it RRD. Will appreciate if this is a bug or therewise.

2. When we tried version 1.6, the database is not refreshed immediately, we need to press the refresh button to get the latest data from the database.
But when we tried version 1.7, the database is refreshed immediately. The concern if the report a simple report and no parameter, it works perfectly fine. We have report that needs parameter to select and takes 20 mins to run to get the desired output. It seems there is no button to stop the "auto" fresh. Please advise if this is the intended design in version 1.7. If yes, when parameter is required for complex report which takes a long time to run, does it mean we need to install 1.6.

Will appreciate your advise.

Thanks and Best Regards,
Siew Poon
The administrator has disabled public write access.

Re:Error Connecting to Oracle ODBC 06 Aug 2012 15:28 #1059

  • sduranceau
  • sduranceau's Avatar
  • Offline
Hi Siew Poon!

1. This is not actually a bug, but rather a change in the way the Crystal Reports 2011 programming controls work as opposed to Crystal Reports 2008. We are currently looking into a way to suppress this message to avoid confusion but do not currently consider it a bug.

2.To make it work like 1.6, all you simply have to do is uncheck the "Discard Saved Data" checkbox, underneath the File Name tab in Solution Builder.


I hope this helps!
-Devin
Attachments:
The administrator has disabled public write access.

Logicity Logo White 300

526 S Main St., Suite 805, Akron, OH 44311 USA
855.758.0100
sales@logicitysuite.com