TOPIC: More than 500 entries on a dynamic parameter

More than 500 entries on a dynamic parameter 18 Mar 2009 20:39 #410

  • mattholbrook
  • mattholbrook's Avatar
If you have more than 500 entries on a dynamic parameter drop-down only 500 show. You can adjust this by doing the following:

Logicity Update
HKEY_LOCAL_MACHINE\SOFTWARE\Business Objects\Suite 12.0\Crystal Reports\DatabaseOptions\LOV
Add DatabaseOptions under Crystal Reports.
Add LOV under DatabaseOptions.
Add Stringkey MaxRowsetRecords under LOV
Set value to maximum number of records to read (for Talon, use 20000).

Crystal Reports Development Update
HKEY_LOCAL_MACHINE\SOFTWARE\Business Objects\Suite 11.0\Crystal Reports\DatabaseOptions\LOV
Add LOV under DatabaseOptions.
Add Stringkey MaxRowsetRecords under LOV
Set value to maximum number of records to read (for Talon, use 20000).
The administrator has disabled public write access.

More than 500 entries on a dynamic parameter 12 Nov 2012 14:13 #1221

  • aellis
  • aellis's Avatar
  • Offline
Note that the registry locations have been revised for Logicity 1.7. The 'DatabaseOptions' key is now located at:

HKEY_LOCAL_MACHINE\SOFTWARE\SAP Business Objects\Crystal Reports for .NET Framework 4.0\Crystal Reports\DatabaseOptions\

if you are on a 64-bit PC this key is located at:

HKEY_LOCAL_MACHINE\SOFTWARE\Wow6432Node\SAP Business Objects\Crystal Reports for .NET Framework 4.0\Crystal Reports\DatabaseOptions\
The administrator has disabled public write access.

More than 500 entries on a dynamic parameter 01 Mar 2013 12:13 #1306

  • CarlyByrnes
  • CarlyByrnes's Avatar
  • Offline
  • Tukaram
aellis wrote:
Note that the registry locations have been revised for Logicity 1.7. The 'DatabaseOptions' key is now located at:

HKEY_LOCAL_MACHINE\SOFTWARE\SAP Business Objects\Crystal Reports for .NET Framework 4.0\Crystal Reports\DatabaseOptions\

if you are on a 64-bit PC this key is located at:

HKEY_LOCAL_MACHINE\SOFTWARE\Wow6432Node\SAP Business Objects\Crystal Reports for .NET Framework 4.0\Crystal Reports\DatabaseOptions\

I was having the same kind of problem, but thanks to you now my issue is resolved.
The administrator has disabled public write access.

Logicity Logo White 300

526 S Main St., Suite 805, Akron, OH 44311 USA
855.758.0100
sales@logicitysuite.com